HomeCalendarFAQUsergroupsRegisterLog in

Share
 

 wont run

Go down 
AuthorMessage
94_se-r

94_se-r

Posts : 58
Join date : 2011-01-05
Age : 33
Location : baraboo

wont run Empty
PostSubject: wont run   wont run EmptySun Mar 06, 2011 5:23 pm

my cousin has a 240 with a rb20det swap in it he was driving it last fall and it just died.... towed it home and changed the fuel filter the next day thinking that might be it and it started ran for about 10 min then again dead... I pulled the plugs and they were soaked let it dry out and started again. I didnt know anything about the rb20's at that time so I was lost, we brought it down to a shop in madison, and the guy thought it might be wiring so he spent like 2 months screwing with it, fixed a bunch of wiring and changed the MAF, ing. module, ECU, plugs, & coils. After that it still wouldnt stay running so we brought it home I noticed when it did run it was extremely rich. Would bad injectors cause this? I have my cousin trying to find a stock FPR for the RB20 but its not easy, I know a bad FPR can cause this but it doesnt seem to bad it has good FP with the key on, cranking, and running???? any help would be greatly appreciated. thanks Will
Back to top Go down
93sapphirecoupe



Posts : 113
Join date : 2010-11-10
Location : northern il

wont run Empty
PostSubject: Re: wont run   wont run EmptySun Mar 06, 2011 9:33 pm

have you checked for a charge pipe blown off? or big vacuum leak?
Back to top Go down
94_se-r

94_se-r

Posts : 58
Join date : 2011-01-05
Age : 33
Location : baraboo

wont run Empty
PostSubject: Re: wont run   wont run EmptySun Mar 06, 2011 9:47 pm

Checked for both and nothing
Back to top Go down
Big Ben
Admin
Big Ben

Posts : 732
Join date : 2009-09-23
Age : 37
Location : Madison, WI

wont run Empty
PostSubject: Re: wont run   wont run EmptyMon Mar 07, 2011 8:43 am

If he cant find a stock one, have him get an aftermarket adjustable fuel pressure regulator. It sounds like a fuel problem, like it is fouling plugs out. Are all of the plugs wet or just some?
Back to top Go down
94_se-r

94_se-r

Posts : 58
Join date : 2011-01-05
Age : 33
Location : baraboo

wont run Empty
PostSubject: Re: wont run   wont run EmptyMon Mar 07, 2011 10:06 am

All the plugs are wet which makes me think fpr what should the fp be if I remember correctly it was like 40-45psi before
Back to top Go down
93sapphirecoupe



Posts : 113
Join date : 2010-11-10
Location : northern il

wont run Empty
PostSubject: Re: wont run   wont run EmptyMon Mar 07, 2011 11:34 am

thats correct. did you ever check for codes?
Back to top Go down
94_se-r

94_se-r

Posts : 58
Join date : 2011-01-05
Age : 33
Location : baraboo

wont run Empty
PostSubject: Re: wont run   wont run EmptyMon Mar 07, 2011 12:31 pm

i did check for codes and there arent any. I am going to try the fpr but if that doesnt do it I am lost. If anyone wants to help figure it out I will supply the beer and food...
Back to top Go down
93sapphirecoupe



Posts : 113
Join date : 2010-11-10
Location : northern il

wont run Empty
PostSubject: Re: wont run   wont run EmptyMon Mar 07, 2011 12:48 pm

i would double check everything that is associated with the maf. just because you took it to a shop doesnt mean they know what they are doing. ive had to fix stuff before that shops have done. the main things that make it flood out like that are the maf, intake air temp (which is in the maf) coolant temp. or map which your car doesnt have. just my 2c
Back to top Go down
94_se-r

94_se-r

Posts : 58
Join date : 2011-01-05
Age : 33
Location : baraboo

wont run Empty
PostSubject: Re: wont run   wont run EmptyMon Mar 07, 2011 1:15 pm

I will check the maf and make sure everything looks good. thanks
Back to top Go down
94_se-r

94_se-r

Posts : 58
Join date : 2011-01-05
Age : 33
Location : baraboo

wont run Empty
PostSubject: Re: wont run   wont run EmptyMon Mar 07, 2011 7:33 pm

well I went out to my cousins and put the adj. fpr on the 240 and it started right up. We let it run for about 45min and aside from a slight misfire it ran good. shut it off and tryied to start it back up and nothing. Pulled the plugs and they were wet but not soaked figured they were fouled out from being flooded so much so we put new ones in and still nothing it has spark and fuel, it tried to start but nothing. The maf seems to be fine the wiring all looks good. I am at a loss....
Back to top Go down
insane imports



Posts : 278
Join date : 2009-11-29
Age : 36
Location : kimberly, WI

wont run Empty
PostSubject: Re: wont run   wont run EmptyMon Jan 16, 2012 11:41 pm

Old thread but did you guys ever get this sorted out?
Back to top Go down
http://www.cardomain.com/id/insaneimport2000
94_se-r

94_se-r

Posts : 58
Join date : 2011-01-05
Age : 33
Location : baraboo

wont run Empty
PostSubject: Re: wont run   wont run EmptyTue Jan 17, 2012 4:50 pm

He sold the car, but the guy that bought it did get it fixed after he put a complete harness in it I believe.
Back to top Go down
insane imports



Posts : 278
Join date : 2009-11-29
Age : 36
Location : kimberly, WI

wont run Empty
PostSubject: Re: wont run   wont run EmptyWed Jan 18, 2012 1:24 am

Nice. Wiring can be a complete nightmare if you don't know what tprevious owner did to it.
Back to top Go down
http://www.cardomain.com/id/insaneimport2000
Sponsored content




wont run Empty
PostSubject: Re: wont run   wont run Empty

Back to top Go down
 
wont run
Back to top 
Page 1 of 1
 Similar topics
-
» Rhino wont start
» Engine wont turn over with spark plugs in.
» pulley bolt wont budge..help!
» Best way to get your rear Rim off of Transaxle that wont budge.
» need help quick! Kohler Command wont crank.

Permissions in this forum:You cannot reply to topics in this forum
Mid-West Nissans :: Platforms :: 240SX-
Jump to: